Wednesday, April 6, 2011

KDE 4.6.2 - looking for testers!

You may already have heard that a new version of the desktop environment came out today. (No, not the other one.) I'm talking about KDE 4.6.2. It is in my opinion shaping up rather well, and we in the Gentoo KDE team consider it a candidate for stabilization in a while. (It's about time, since upstream considers our "stable" KDE 4.4 rather "dead".) You can look up the list of important known issues on our bugzilla; some of this definitely has to be fixed before stabilization, but on the whole the list looks manageable.
So, we need testers. Especially since we all from the KDE team have been running newer KDE versions for ages by now and have never tried the direct step from 4.4 to 4.6. If you are brave - sync your portage tree, grab the keyword file, place it in /etc/portage/package.keywords - and update your system! As additional bonus, you will get also updates for QT, koffice, digikam, and some more packages...
If there are dependencies missing in the keyword file, please file a bug! If you encounter any build problems, please file a bug! If you see any misbehaviour after the upgrade, please file a bug! Thanks a lot in advance!
Oh yes, one last note. The kdepim guys obviously don't feel like releasing at all, so everything from kmail to blogilo will remain at trusty version 4.4. This is, however, nothing to worry about. (I'd worry a lot more about the kdepim update should it ever happen...)

10 comments:

  1. I've synced my portage tree two days ago and got all KDE 4.6.2 packages. But I couldn't fetch any package. This morning I could finally fetch all KDE 4.6.2 related packages for upgrading, I did a 'layman -S' and all updates dissapeared.

    This is not the first time that this happens; all of that happened when 4.6.1.

    ReplyDelete
  2. Yes because the ebuilds were moved from the overlay to main tree. Always sync your overlays and tree together to avoid similar issues.

    ReplyDelete
  3. I am building right now on my i7 desktop. I will file bug reports if I find any bugs..

    ReplyDelete
  4. @acidrums4:
    This issue is caused by you having kde unmask file in /etc/portage/package.unmask.
    The 4.6.2 resided in overlay MASKED until the time i commited it to main tree, where it was unmasked and with availible sources to download.

    If i would say it shortly it is just PEBKAC :P

    ReplyDelete
  5. Great update! I'm using since yesterday.
    I've noticed, so far, a more emphatic window focus system, graying a bit more the unfocused one. Cool.

    I had to manually uninstall all kde-4.5 and kde-4.4 packages to solve blocks, because some of them was creating a PyQT4 version conflict.
    But it was not sleep taking :)

    ReplyDelete
  6. @oandarilho01: Thanks! There's lots of cool stuff that you can configure in the systemsettings. About the only eye candy that I'm missing is the "burning windows" from Compiz. :)

    If you or anyone else have the PyQt4 version conflict problem again, please show us the logs (on irc or in a bug report)...

    ReplyDelete
  7. Hi - I upgraded from 4.4 to 4.6 some time ago. Since then I have moved up to 4.6.2. I had a few issues - ripping DVD's and using dolphin to display the files in Dragon caused my whole desktop to disappear. In an effort to debug this I enabled splitdebug and did an emerge world - since then this problem disappeared - I think the emerge world fixed it as some other things started working correctly (Raid for example). For this reason I would recommend that an emerge world be done.
    Latest update today has caused kdevplatform to fail to emerge as it is incompatible with kde 4.5 and later - already bug reported on this. I don't know how it compiled successfully against 4.6.1 though.
    The desktop feels much more responsive. I also removed HAL - this caused k3b to fail to recognise any DVD in the drive - rebooting fixed this - some incorrect interaction between kde and udisks I suspect.
    Otherwise very pleased with it - kde 4 is now usable like kde 3.5.2 was . Only gripe is that knetattach still does not do ssh correctly - at least I could not get it to work and the error message is uninformative

    ReplyDelete
  8. "I also removed HAL - this caused k3b to fail to recognise any DVD in the drive - rebooting fixed this - some incorrect interaction between kde and udisks I suspect."

    ^ That's to be expected; to make applications really aware that hal is gone, you'll have to reboot.

    ReplyDelete
  9. I've istalled kde 4.6.2 and for the moment no big issue (only 2 crash without problem of amarok).
    For the moment i'm unable to setting the monitor light with Fn + (F5-F6) of my laptop.....i think caused by disabling and unistall of hal....someones can explain some solution?

    ReplyDelete